Following a period of system monitoring, this issue appears to be resolved. Please contact help@dtect.net with any follow up questions or concerns.
Posted Jun 18, 2024 - 13:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2024 - 18:25 UTC
Investigating
We are currently investigating a user-reported issue; logging in to the system is currently inaccessible. Further information will be provided as available.